Version 5 maintenance/support subscription explained

As of Syncplify.me Server! version 5.x, we’ve applied a few technical changes in the way the maintenance/support subscription works. Nothing has changed from a philosophical/legal standpoint, only the technology has changed.

Just as before, you need an active maintenance/support subscription to:

  • install updates/upgrades to the software
  • receive customer support
  • be eligible for discounts and special offers

So, what’s new? Continue reading

Everything you need to know about Syncplify.me Server! V5 license codes

In this article we provide a compendium, sort of a FAQ, regarding the most common questions and pieces of knowledge that every Syncplify.me Server! user should know about the new version 5.x licensing system. So here we go:

What’s the license code format?

V5 license codes look like this: V5XX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX

Will my old (V4, V3, …) license code work if I upgrade to V5?

Continue reading

How to upgrade Syncplify.me Server! from V4 to V5

The video here below shows the recommended procedure to upgrade your Syncplify.me Server! from version 4.x to the new version 5.x.

This article assumes you’ve already read and understood the following 2 knowledge base articles, before you attempt the upgrade process:

It is recommended, before upgrading to v5.x, to make sure that you’re running the latest version 4, which is v4.2.5.

Also, it should go without saying (but we say it anyway), that prior to any major upgrade like this you should always make sure to take a snapshot or a full backup of the machine/VM running your existing version. This way, should anything go wrong during the upgrade, you can always go back to your old v4.x in no time.

Last but not least, the “magic URL” mentioned in the video, the one to backup your old v4.x configuration is:

 

What’s new in Syncplify.me Server! v5

Syncplify.me Server! version: 5.0.0+

While the step from v3 to v4 was somewhat “epic” (as 80%+ of the code was rewritten from scratch) the upcoming Syncplify.me Server! v5 will, instead, build upon the rock-solid foundation of v4 and expand and improve its features significantly. Version 5 will also be our most cloud-enabled version to date.

Here’s a list of some of the most important upcoming new features our users will find in Syncplify.me Server! v5: Continue reading

Syncplify.me Server! v4.0.12 released

We have just released version 4.0.12 of our Syncplify.me Server! software. This version features the following improvements:

  • Fixed a memory leak in the Log Server component
  • Fixed directory listing bug that affected Transit and CODA2 clients on Mac
  • Added option to activate/deactivate specific protocol servers (in the Node Bindings configuration)
  • Added option to delay rejection of anonymous logins (to make Windows Explorer happy)

Since this update fixes a memory leak, we strongly recommend every Syncplify.me Server! user to install it.

As usual you can download this new release from our website.

Syncplify.me Server! v4.0.9 released

We have just released version 4.0.9 of our Syncplify.me Server! software. This version features the following improvements:

  • Added brand new “zero configuration” option to the HTTP/REST Configuration Wizard
  • Added auto-selection of an alternate port for the HTTP/REST service if 443 is busy (without overwriting your IIS certificate)
  • Fixed a bug in Active Directory Group support (also read this article)
  • Fixed a stability bug in the REST API service which was affecting only Windows 2012 R2

As usual you can download this new release from our website.

Syncplify.me Server! v4.0.2 Released!

We have just released version 4.0.2 of our Syncplify.me Server! software. This hot-fix release was necessary to address an issue with some of the upgrades from version 3.x to version 4.0 where – at times – a “path not found” error could appear during the upgrade process.

We apologize for any inconvenience, and recommend anyone that needs to upgrade from version 3.x to download this new hot-fix release.

Syncplify.me Server!: upgrading to version 4.x

Syncplify.me Server! version: 4.0.0+

Syncplify.me Server! v4 is more than just a major release. The software was totally redesigned and nearly entirely rewritten. The back-end database is new, both in structure (JSON) and with regards to the engine (MongoDB). The virtual file system (VFS) implements a true separation of the file transfer engine and the storage. Management is now entirely based on a rich set of REST API, to which we provide 2 front-ends: a modern Boorstrap/AngularJS secure web interface, and a completely redesigned CLI (command-line interface). For all these reasons, in order to upgrade to version 4 and keep your configuration and user database, you will have to carefully follow the procedures explained in this article, and especially in the VIDEO here below. Continue reading

Syncplify.me Server! v4: new license code format

Syncplify.me Server! version: 4.0.0+

This is a little, yet relevant, difference between Syncplify.me Server! v3 and v4. Version 3’s license codes were composed of 3 chunks of 4 digits each (ex: 1234-1234-1234) while the new v4 features license codes composed of 4 chunks of 4 digits each (ex: 1234-1234-1234-1234).

This means that v3 licenses are not compatible with v4. If you are an existing customer with an active support/maintenance and upgrade protection subscription, you will still need to contact us (before upgrading from v3 to v4) in order to request your new v4 license code. As usual, all v3 customers with an active subscription will be entitled to a FREE upgrade to v4.

Maintenance release: Syncplify.me Server! v3.1.16.56

We have just released version 3.1.16.56 of our Syncplify.me Server!

This new maintenance release fixes a bug in the FileToString function that was erroneously assuming the file encoding was always UTF. Now the file encoding is properly detected before the “read” operation takes place.

As usual you can download the latest version from our web site. Thank you!