How to upgrade Syncplify.me Server! from V4 to V5

The video here below shows the recommended procedure to upgrade your Syncplify.me Server! from version 4.x to the new version 5.x.

It is recommended, before upgrading to v5.x, to make sure that you’re running the latest version 4, which is v4.2.5.

Also, it should go without saying (but we say it anyway), that prior to any major upgrade like this you should always make sure to take a snapshot or a full backup of the machine/VM running your existing version. This way, should anything go wrong during the upgrade, you can always go back to your old v4.x in no time.

Last but not least, the “magic URL” mentioned in the video, the one to backup your old v4.x configuration is:

 

Syncplify.me Server! v4.2.5 released

We have just released version 4.2.5 of our Syncplify.me Server! software. This version features the following improvements:

  • Fixed: issue that prevented some secondary nodes in HA deployments from creating their own system services

Warning: upgrading to this version from any version prior to 4.0.34 will invalidate your license, so please if you are a customer – before you upgrade – contact us to request a license reset.

Note: if after the update you notice any unexpected behavior in the web interface, just hit Ctrl-F5 in your browser; that will force the browser to reload the page as well as all back-end scripts and update the ones that may have been cached from previous versions of the software.

As usual you can download this new release from our website.

Syncplify.me Server! v4.2.4 released

We have just released version 4.2.4 of our Syncplify.me Server! software. This version features the following improvements:

  • Fixed: occasional lingering of sockets in CLOSE_WAIT status when behind firewalls that act as proxies
  • Fixed: occasional huge delay upon accepting new connections when the number of VFSs is high

Warning: upgrading to this version from any version prior to 4.0.34 will invalidate your license, so please if you are a customer – before you upgrade – contact us to request a license reset.

Note: if after the update you notice any unexpected behavior in the web interface, just hit Ctrl-F5 in your browser; that will force the browser to reload the page as well as all back-end scripts and update the ones that may have been cached from previous versions of the software.

As usual you can download this new release from our website.

Syncplify.me Server! v4.0.9 released

We have just released version 4.0.9 of our Syncplify.me Server! software. This version features the following improvements:

  • Added brand new “zero configuration” option to the HTTP/REST Configuration Wizard
  • Added auto-selection of an alternate port for the HTTP/REST service if 443 is busy (without overwriting your IIS certificate)
  • Fixed a bug in Active Directory Group support (also read this article)
  • Fixed a stability bug in the REST API service which was affecting only Windows 2012 R2

As usual you can download this new release from our website.

Syncplify.me Server! v4.0.8 released

We have just released version 4.0.8 of our Syncplify.me Server! software. This version features the following improvements:

  • Support for Windows XP, Server 2003, Server 2003 R2, and Vista
  • Fixed a bug that prevented the import of user keys in RSA format
  • Fixed a bug that prevented the correct behavior of AllowFTP, AllowFTPS, and AllowFTPES

As usual you can download this new release from our website.

Syncplify.me Server! v4.0.7 released

We have just released version 4.0.7 of our Syncplify.me Server! software. This version features the following improvements:

  • Fixed few glitches in the SuperAdmin (SA) interface relative to High-Availability (HA) deployments
  • Better support for Internet Explorer (still not the recommended browser though)

We will also soon support older operating systems (Windows XP, Server 2003 and 2003R2, Vista). We will post a notice here on the knowledge base as soon as legacy OS installers are made available.

As usual you can download this new release from our website.

Syncplify.me Server! v4.0.6 released

We have just released version 4.0.6 of our Syncplify.me Server! software. This version features the following improvements:

  • Two distinct PCI-compliant configurations to prevent backward compatibility issues
  • Better support for Internet Explorer (still not the recommended browser though)
  • Fixed an issue with self-signed X.509 certificate serial numbers

As usual you can download this new release from our website.

Syncplify.me Server! v4.0.5 released

We have just released version 4.0.5 of our Syncplify.me Server! software. This version improves compatibility with Internet Explorer (Chrome and Firefox were already perfectly supported) and fixes a couple of little glitches in the web interface.

Note: regardless of these improvements, Internet Explorer is still causing a lot of trouble, so we strongly recommend to use a better browser and limit the use of IE to view-only/read-only situations. Chrome and Firefox, on the other hand, work like a charm and can be used for all your configuration purposes.

As usual you can download this new release from our website.